configure.ac

changeset 367
e54e0b24e98e
parent 362
39cef8f37eb5
child 368
97c53f7ef5e4
--- a/configure.ac	Wed Nov 06 16:27:54 2019 +0100
+++ b/configure.ac	Wed Nov 06 20:34:54 2019 +0100
@@ -28,6 +28,7 @@
 
 # the package version must match the macros in ucx.h
 # the lib version must follow the libtool versioning convention
+AC_PREREQ([2.60])
 AC_INIT([ucx], [2.1.0], [olaf.wintermann@gmail.com])
 AC_SUBST([UCX_LIB_VERSION], [4:0:1])
 
@@ -44,20 +45,17 @@
 # we are compiling a library
 LT_INIT
 
-# we are dealing with C source code
-AC_PROG_CC
+# we want c11, and may fall back to c99
+AX_CHECK_COMPILE_FLAG([-std=c11],
+    [AX_APPEND_FLAG([-std=c11])],
+    AC_PROG_CC_C99
+)
 
 # we want to support automake < 1.14, so we need this deprecated macro
 # it tests, whether the compiler allows -c and -o simultaneously
 # in modern versions of autoconf, this is done by AC_PROG_CC
 AM_PROG_CC_C_O
 
-# we want c11, and may fall back to c99
-AX_CHECK_COMPILE_FLAG([-std=c11],
-    [AX_APPEND_FLAG([-std=c11])],
-    [AC_PROG_CC_C99]
-)
-
 # where to place config macros
 AC_CONFIG_HEADERS([config.h])
 

mercurial