configure.ac

changeset 362
39cef8f37eb5
parent 341
b9715d7317c1
child 367
e54e0b24e98e
--- a/configure.ac	Sat Oct 05 17:07:16 2019 +0200
+++ b/configure.ac	Sun Nov 03 15:35:29 2019 +0100
@@ -52,8 +52,11 @@
 # in modern versions of autoconf, this is done by AC_PROG_CC
 AM_PROG_CC_C_O
 
-# we require the current C standard
-AC_PROG_CC_STDC
+# we want c11, and may fall back to c99
+AX_CHECK_COMPILE_FLAG([-std=c11],
+    [AX_APPEND_FLAG([-std=c11])],
+    [AC_PROG_CC_C99]
+)
 
 # where to place config macros
 AC_CONFIG_HEADERS([config.h])

mercurial