test/CMakeLists.txt

changeset 653
e081643aae2a
parent 652
bf817b825ed2
child 654
c9d008861178
--- a/test/CMakeLists.txt	Tue Feb 07 21:53:06 2023 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,32 +0,0 @@
-# Load Google Test Framework
-set(CMAKE_CXX_STANDARD 17)
-
-include(FetchContent)
-FetchContent_Declare(
-        googletest
-        GIT_REPOSITORY https://github.com/google/googletest.git
-        GIT_TAG e2239ee6043f73722e7aa812a459f54a28552929 # release 1.11.0
-)
-# For Windows: Prevent overriding the parent project's compiler/linker settings
-set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
-FetchContent_MakeAvailable(googletest)
-include(GoogleTest)
-message(STATUS "Google Test made available")
-
-add_executable(ucxtest
-        test_utils.cpp
-        test_allocator.cpp
-        test_compare.cpp
-        test_string.cpp
-        test_buffer.cpp
-        test_list.cpp
-        test_tree.cpp
-        test_hash_key.cpp
-        test_map.cpp
-        test_basic_mempool.cpp
-        test_printf.cpp
-        selftest.cpp
-        util_allocator.cpp
-        )
-target_link_libraries(ucxtest PRIVATE ucx_static gtest_main)
-gtest_discover_tests(ucxtest)

mercurial