test/CMakeLists.txt

changeset 511
a32e6a6b1ca7
parent 510
133ac0f8f3fc
child 512
096d206b63f9
--- a/test/CMakeLists.txt	Fri Apr 15 21:28:51 2022 +0200
+++ b/test/CMakeLists.txt	Sat Apr 16 08:49:31 2022 +0200
@@ -9,7 +9,6 @@
 if (CUNIT_FOUND)
     message(CHECK_PASS "found: compiling tests.")
     set(TESTS
-            test_allocator
             test_list
             test_tree
     )
@@ -41,9 +40,10 @@
 
 set(TESTS
         selftest
+        test_allocator
         )
 foreach (test ${TESTS})
     add_executable(${test} ${test}.cpp)
     target_link_libraries(${test} PRIVATE ucx_static gtest_main)
+    gtest_discover_tests(${test})
 endforeach ()
-gtest_discover_tests(${TESTS})

mercurial